Регистрация

Повышение системных требований DataLife Engine

TipTop 18-01-2010, 17:57 2328 Разное

Дорогие друзья,

Постепенно приходит время когда необходимо увеличивать требования к минимально установленному ПО, чтобы скрипт мог продолжать свое развитие.

В данном случае речь пойдет о версии PHP установленном на сервере. На данный момент минимальным требованием к PHP, является версия 4.3.x и выше, однако четвертая линейка тормозит развитие скрипта, поэтому все таки необходимо тем у кого на сервере установлена еще четвертая линейка, переходить на PHP5.

Итак начиная с новой версии скрипта, рекомендуемой версией PHP, будет является версия 5.1.0 и выше. Это необходимо будет для поддержки новых функций DataLife Engine, одной из таких будет например возможность ZIP сжатия JS файлов скрипта, в результате которой их размер будет меньше в несколько раз, и соответственно намного быстрое их загрузка, а также принудительное кеширование их в браузере, чтобы они потом не загружались повторно.

Наличие PHP5 не будет минимальным требованием для новой версии, и DataLife Engine сможет работать на PHP4, но он автоматически отключит не поддерживаемые новые возможности. И с каждой версией таких отключаемых возможностей будет все больше и больше.

Поэтому просьба все таки найти время и обновить безнадежно устаревший PHP4 на PHP5, пока есть еще время сделать это не спеша и не торопясь.

автор: celsoft

Другие публикации по категории:

Статья оптимизируем под SEO сайт на DLE

DLE Forum (Правка бага с редактированием поста)

DataLife Engine стукнуло 5 годков

Статья Upgrade файлов для DLE

Урок по созданию install.php


Информация
Посетители, находящиеся в группе Гости, не могут оставлять комментарии к данной публикации.
Powered by Dleshka.org. Сайт предназначен для выбора шаблонов и дополнений с использованием CMS DataLife Engine.
Закрыть