» » Облако тегов как на Wordpress для DLE 8.2

Облако тегов как на Wordpress для DLE 8.2

Облако тегов как на Wordpress для DLE 8.2


Облако тегов как на Wordpress для DataLife Engine 8.2


Данный модуль представляет собой переделку уже существующего Хака, но новшество его заключается в совместимости с новой версией DataLife Engine 8.2, а именно - возможность подключить красивое облако тегов только лишь через шаблон, без редактирования кода файлов движка.

Для установки достаточно скопировать файлы из архива на сервер, а в нужном месте в main.tpl добавить соответствующий тег. Подробнее - в инструкции.

Внимание! У вас нет прав для просмотра скрытого текста.




Комментарии

Warning: Division by zero in...engine\modules\tagscloud2.php on line 60
Вылезает при добавлении тегов

TipTop

Администраторы 5 октября 2009 23:32
Открой файл engine\modules\tagscloud2.php найди строку
foreach ($tags as $tag => $value) {


Вот это:
foreach ($tags as $tag => $value) {

$list[$tag]['tag'] = $tag;
$list[$tag]['size'] = $sizes[sprintf(\"%d\"
;, ($value-$min)/$range*4 )];


Замени на:
foreach ($tags as $tag => $value) {

$list[$tag]['tag'] = $tag;
if ($range == 0) $list[$tag]['size'] = $sizes[0];
else $list[$tag]['size'] = $sizes[sprintf(\"%d\"
;, ($value-$min)/$range*4 )
b]TipTopb],
если заменить выскакивает это:
Warning: Unexpected character in input: '\' (ASCII=92) state=1 in \httpdocs\engine\modules\tagscloud2.php on line 61 Parse error: syntax error, unexpected T_STRING in \httpdocs\engine\modules\tagscloud2.php on line 66

TipTop

Администраторы 6 октября 2009 23:36
ENDorFiN,
Насчет этой ошибки xз 99% то что возможно сделал где-то ошибку еще раз проверь то-что я написал выше ,это и есть лекарство.
у вас пару ошибок в коде Если их исправить всё работает, но опять же теги не добавляются, просто не выскакивает ошибка
Невозможно загрузить шаблон: enginemodulestagscloud2 и вообще нефига не робит
ну ктонить разобрался, а то мод то красивый и функциональный...

TipTop

Администраторы 24 января 2010 09:26
Пререзалил обновленный архив на сервер.МОДУЛЬ ПРОВЕРЯЛ 100% РАБОЧИЙ. Даже пофиксина ошибка в модуле
Division by zero...
Инструкция по установке внутри.Все делаем как там написано и модуль заработает.
На других сайтах почему то у меня показывает облако тегов а на моем сайте вот так пигет: Требуется для просмотраFlash Player 9 или выше.

Что делать подскажите.Заранее Благодарю
Я делал так 100% работает......Кидаю папку tagcloud в папку image (на вашем шаблоне ) и в main.tpl там пишем вместо
var tagcloud_cl = new SWFObject("/engine/classes/tagcloud/tagcloud.swf", "tagcloud", "190", "190", "9", "#ffffff");

ПИШЕМ
var tagcloud_cl = new SWFObject("{THEME}/images/tagcloud/tagcloud.swf", "tagcloud", "170", "170", "9", "#6fffff");

У самого било тоже и флеш не вставляло на сайт......так и флеш прописовать нада {THEME}/images/моя флеш.....


Должно сработать 1000%



............Если кто подскажет где в облаке шрифт прописать нифига не пойму что на что менять ... wink
пасиба за фикс
у меня всё работает, но интересует вопрос, как сделали вот это _http://lost-abc.ru/ в центре облака картинка, есть ли возможность это сделать для DataLife Engine???
Заранее спасибо!!!
У меня пишет Требуется для просмотраFlash Player 9 или выше что сделать подскажите пожалуйста
перезалейте плз, хз что но архив после скачивания не открывается, пишет что поврежёдн

TipTop

Администраторы 23 сентября 2010 20:35
Цитата: luksor
luksor


Архив перезалил.
Давно эта тема не поднималась)
Смотрю народ оживился
Возможна ли переделка на 9.4 ?
этих файлов нет
alltagscloud_ваш_шаблон.tmp , tagscloud_ваш_шаблон.tmp , tags_all_view_ваш_шаблон.tmp
есть только
tagscloud_be4aa0c8e2d7f103752fb6bc814d5d02.tmp
tags_all_view_be4aa0c8e2d7f103752fb6bc814d5d02.tmp
informer_1_be4aa0c8e2d7f103752fb6bc814d5d02.tmp
что делать???

Информация

Посетители, находящиеся в группе Гости, не могут оставлять комментарии к данной публикации.


Личные сообщения

Ваши переписки